
 
 
 
 

Vissim  
(Version 11)  

 
Module 6:  

Data and Performance 
Metrics 

 
 
 

Georgia Institute of Technology 
 

Latest Update: 8/10/2021 
 

 Contact: 
Michael Hunter 

Michael.Hunter@ce.gatech.edu 
 
 
Disclaimer: The objective of these tutorials is to bring new users sufficiently (and quickly) up to speed so they can 
use the manual and other resources when they have questions on model development. These tutorials should not be 
considered as official guidance; users should always refer to official PTV Vissim or project sponsor documentation 
for the final word on a model feature question. Send any errors, issues, or comments to michael.hunter@ce.gatech.edu 
so any corrections can be made to the material. 
  



PTV-Vissim (V11) Module 6 Overview 
This is the sixth in a series of Vissim modules. Module 1 guides the user through the creation 
of a corridor which consists of three signalized, pre-time, four-approach intersections. Module 
2 adds coordinated-actuated control to the corridor from Module 1. Module 3 adds an 
unsignalized intersection. Module 4 familiarizes the user with the basics of designing a freeway 
segment with a diamond interchange. Module 5 introduces additional concepts and tips for 
building and reviewing a Vissim model, exploring some of the Vissim modeling issues not 
covered in the first four modules (allowing a user to quickly get up to speed) but critical to 
model development. Module 6 shows how to collect various performance measures: travel 
time, speed, delay, queues, etc., including many of the numerous Vissim data elements for each 
of these metrics. Module 6 assumes the user is familiar with the concepts in the prior five 
modules and will build on the final .inpx developed in Module 5. The wireframe of this model 
is seen in Figure 1.   
 
 

 

 
Figure 1: Module 5 Final Network Configuration 

 
 
 
 
   



Module 6 will step through six primary topics: 
1. Travel time, 
2. Delay, 
3. Volume and speed (Data Collection Points), 
4. Queues, 
5. Node and link based metrics, and 
6. Signal control and detector data. 
 

Base Knowledge  
For this module, it is assumed that you have a basic understanding of the concepts covered in 
Modules 1 through 5, including: 
 

• Starting Vissim and navigating the GUI (Graphical User Interface), 
• Links and Connectors, 
• Signal Controllers, Signal Groups, and Signal Heads, 
• Ring Barrier Control, 
• Alternate intersection and ramp link-connector layouts, 
• Emergency Stop Distance and Lane Change Distance, and 
• Conflict Areas. 

 
 

IMPORTANT: SAVE FREQUENTLY AS YOU WORK! 
 

Create Module 6 Vissim File 
To start open the Module 5 Vissim .inpx file.  Save the .inpx under a new name, e.g. Module 
6. Let’s also update the RBC controllers to: 

• RBC_Mod6_Buzz_and_Burdell_v1.rbc, 
• RBC_Mod6_Buzz_and_Ramblin_v1.rbc, 
• RBC_Mod6_Buzz_and_Pi_v1.rbc,  
• Mod 6 Buzz Blvd and Peach Freeway West Int.rbc, and 
• Mod 6 Buzz Blvd and Peach Freeway East Int.rbc. 

Detailed instructions on opening and saving a Vissim file, as well as renaming RBC 
controllers, may be found in the prior modules.  



Exploring Vissim Data Output and Performance Metrics 
Vissim has a multitude of data outputs and performance metrics that are extremely useful for 
analyzing the performance of a design in simulation. However, these metrics are also highly 
useful for reviewing, validating, and calibrating a model. In this section you will explore many 
of the more common data outputs and performance metrics.  

There are two options for recording most performance metrics. The first is in a Results list that 
you can view while the model is running. The results list data may also be saved to a file if 
desired. The results list data is aggregated by user selected intervals, e.g., the average travel 
time over a roadway segment every 15 minutes. The second is Direct Output of individual 
vehicle performance metric raw data to a file, e.g., the travel time for every vehicle over a 
roadway segment. In the first method - Results List - Vissim performs many of the various 
potential data aggregations for you, in the second method - Direct Output - the raw 
performance measure data is written to a file which may then be utilized for post-hoc analysis 
as desired.  We will demonstrate both methods.   

Travel Time 
We will start with travel time, one of the most commonly utilized performance metrics. To 
collect travel times, there are several tasks necessary: define the Travel Time 
Measurements, that is, the roadway segments over which travel time data will be collected; 
define data collection times and intervals for Results; select the desired metrics for the 
Results List; and set if Direct Output of travel time data to a file is desired. We will set up 
travel time measurements end-to-end NB and SB on Peach Freeway, end-to-end EB and 
WB on Buzz Blvd, and over the EB and WB through and left turn movements for Buzz 
Blvd and Ramblin St. The travel time sections are shown in Figure 2.  



 
Figure 2: Location of travel Time measurements 

Set Travel Time Measurement Sections 
To set up the Buzz Blvd EB end-to-end travel time measurement use the following steps: 

step i. Select Vehicle Travel Times in Network Objects. 
step ii. Right-click on the EB link just downstream of the Vehicle Input, Figure 3. 
step iii. Right-click on Buzz Blvd by the EB exit, Figure 3. 
step iv. The Travel Time Measurement pop-up should appear. Set Name: as Buzz 

Blvd EB - End-to-End.  
step v. Select OK. 

 

Figure 3: Buzz Blvd EB Travel Time Start and End Points 

WB Buzz Blvd End-to-End 
EB Buzz Blvd End-to-End 
SB Peach Fwy End-to-End 
NB Peach Fwy End-to-End 
EB Left Buzz and Ramblin 
EB Thru Buzz and Ramblin 
WB Left Buzz and Ramblin 
WB Thru Buzz and Ramblin 

Peach Freeway 

Buzz Blvd 

Ramblin 
St. 

Burdell 
Dr.  

Pi 
Pkwy. 

Varsity Wy. 

Travel Time Measurement Start Travel Time Measurement End 



step vi. Repeat Steps i through v for Buzz Blvd WB end-to-end, Peach Freeway NB 
and SB end-to-end, and over the Buzz Blvd and Ramblin St. EB and WB 
through and left turn movements, Figure 2. There should now be eight travel 
time measurements, Figure 4.   

 
Figure 4: Vehicle Travel Time Measurements List 

 

CRITICAL CONCEPT 

For a vehicle’s data to be included in a travel time measurement it must cross both the start 
and end point markers of the measurement area. Partial trips are not included in calculated 
travel time metrics. To be recognized as crossing a travel time marker you must be sure the 
vehicle is on the link with the travel time marker. That is, where links and connectors meet, 
or links overlap, a vehicle is only considered to cross the travel time marker if the vehicle 
is on the same link or connector as the marker.       

Also, exercise caution on more complicated models (e.g., larger models, models using 
dynamic traffic assignment, etc.).  ANY vehicle that crosses both the start and end point 
travel time markers will be included in the travel time data for that measurement section. 
It is possible that vehicles taking (widely) different paths between the points may be 
included in the same travel time metrics. To avoid this issue in larger models, instead of 
using a single very long travel time measurement you may want to break the desired path 
into several travel time measurement segments, combining the results in your post analysis. 
This can be particularly necessary for models of grid systems.    

 
 
 
 
 



Setting Up Results List 
 

We will first collect aggregate travel times, using the Results List. With a Results List you 
can view aggregate travel times while the model is running and then save the data to a file, 
if desired.  
 

step i. Go to Evaluation → Configuration. 
step ii. Select the Results Attributes Tab, Figure 5. 
step iii.   For Vehicle travel times check the Collect data box. 
step iv.   Set the Interval to 900 (that is 900 seconds, i.e., 15 minutes). 
step v. Leave the From-time at 0 and To-time at 99999, this means we will collect 

data for the entire simulation time.  (In Module 8 we will discuss the use of 
a warm-up period.) 

step vi. Select More…,  
step vii. Select the destination section radio button. This means the reported travel 

times will be associated with the time the vehicle crosses the travel time exit 
marker.   

step viii. Select OK. 
step ix. Select OK. 

 

 
Figure 5: Travel time setting under Evaluation → Configuration → Results 

Attributes 



Select Travel Time Metrics 
 

So far, we have set the location of the travel time measurements as well as the data collect 
time and aggregation interval for the Results List. As a last step we need to determine which 
travel time metrics we would like to collect.   

 
step i. Go to Evaluation → Results Lists → Vehicle Travel Time Results.  

The Vehicle Travel Time Results list should open. By default, the following 
data will be collected:  
 

Vehs(All): The number of vehicles that have crossed the travel time trap, 
TravelTm(All): Average travel time of vehicles that have traversed the travel 

time trap, and 
DistTrav(all): The total distance traversed by a vehicle in a travel time trap. 
 

step ii. While the default travel time metrics are often all you need let’s add a few 
additional travel time metrics so you can see how that is accomplished.  
Select the wrench icon (  ) in the Vehicle Travel Time Results Window. 
The Vehicle Travel Time Results: Select Attributes window should pop-up, 
Figure 6.     

 

Figure 6: Vehicle Travel Time Results: Select Attributes Window 



step iii. Expand Vehicle travel time evaluation at the bottom of the list. 
step iv. Expand Travel time. 
step v. Select Current run x Standard deviation x All types. (This will show the 

value of the standard deviation of the 15-minute values, i.e., for a two-hour 
run it would be the standard deviation of the 8, 15-minute interval average 
values.)  

step vi. Click the green arrow to move the selected attribute to the results list. 
step vii. Select Current run x Minimum x All types, move to selected attributes. (This 

will show the value of the 15-minutes with the lowest value travel time.)  
step viii. Select Current run x Maximum x All types, move to selected attributes. (This 

will show the value of the 15-minutes with the highest travel time.) 
step ix. Expand Vehicle travel time evaluation at the bottom of the list. Move the 

attribute Name to the selected attributes list. (This is the name of the travel 
time measurement.)  

step x. Click OK. 

 

Save the model. (Hopefully you are doing this often!). Run the model. In the Vehicle Travel 
Time Results window, you will see the travel time results populate for each 15-minute 
interval as the model runs. Example results may be seen in Figure 7.   

 
Figure 7: Example Vehicle Travel Time Results 

 
Aside: feel free to explore some of the other attributes. You may notice that Delay 
measurements may be found under the Vehicle travel time evaluation list. If you add the 
delay attributes to the results list you will notice when you run the model that they do not 
populate with values. This is because there are a few additional steps needed to set up the 
delay measurements. These will be demonstrated in the next section.   
 
 



If you wish to perform some post-hoc analysis of the travel time results click on the disk 
icon ( ) in the Vehicle Travel Time Results list. The file save window will pop-up, select 
Save. The file will save as an .att file in the same folder as the .inpx; however, you can 
confirm (or change) this when you save the file. If you select the disk icon with the red 
arrow ( ) the travel time file will automatically be saved at the end of each run.   
 
You can now open the travel time file in Excel (or the analysis software of your choice). 
Remember, the file has an .att extension, so you will need select All Files *.* in Excel to 
open the file. Open the file as Delimited, with Semicolon Delimiters, and General Column 
data format. In the Excel file you will see some header data (file name and location, date, 
Vissim version, etc.), a list of the data collected, and the raw data. You may now plot and 
analyze the data as you wish.  For example, Figure 8 is the recorded travel time for each 
15-minute period, for all 8 travel time segments.    
 

 
Figure 8:  Travel time data per 15-minute interval for each travel time segment 

Save Direct Output File 
Next, we will see how to output the raw travel time data; that is, the individual vehicle 
travel times over each travel time measurement zone. To output the raw travel time data to 
a file we use Direct Output: 

 
step i. Go to Evaluation → Configuration → Direct Output. 
step ii. Check Write to file for Vehicle Travel times (raw data).  

This will output to a .rsr file. For each vehicle that crosses a travel time 
measurement zone the file includes: time stamp, travel time measurement 
number, vehicle number, vehicle type, travel time, delay, and distance 
traveled.  



Caution: As raw data files contain individual vehicle data they can become 
rather large (particularly for large models or long run times) and they tend 
to slow down model run time. 

The .rsr file will be stored by default in the same file as the .inpx file. You can open this 
file in Excel using Semicolon Delimitation. In the file you will see the travel time for every 
vehicle that crosses one of the defined Travel Time Measurement zones. For instance, 
Figure 9 shows the end-to-end EB Buzz Blvd vehicle travel times. In the figure the raw 
data was used to calculate the 15-minute averages as well, these are also plotted. A 
comparison of the 15-minute averages calculated using the raw data and that from the 
Results List show the same aggregate values, as it should be! 

 
Figure 9: Individual vehicle Buzz Blvd EB travel times 

By default, all vehicle types are included in the Results List. However, you can set the 
Results List to combinations of vehicle types, different data intervals, etc.  In addition, 
using the Direct Output you can perform your own post-hoc analysis for combinations of 
vehicle types, different intervals, etc. The raw data provides nearly limitless analysis 
alternatives.   

Delay 
The steps to collect delay performance metrics in Vissim are similar to those used to collect 
travel time. The following demonstrates collecting delay data. Recall, in Vissim a vehicle’s 
delay is defined as the difference in travel time over a segment at the vehicle’s desired 
speed versus the actual travel time. Thus, two vehicles with the same travel time could have 
different delays. 

Vissim uses travel time measurement zones for delay calculations. We will use the same 
travel time measurement zones as defined earlier, so we do not need create new zones; 
however, a user may certainly create travel time measurement zones that are of specific 



interest for delay. (Later we will also see how to use Vissim Nodes to obtain delay 
measures.) First, we need to select the travel time measurement zone(s) for which we want 
to collect delay data. 

step i. Go to Evaluation → Measurement Definitions → Delay Measurements. 
step ii. Currently there are no zones identified. Right-click in the Delay 

Measurements window, select Generate all (1:1). This will create a Delay 
Measurement for each Travel Time Measurement zone.   

step iii. You may also create Delay Measurements that are combinations of Travel 
Time Measurement zones. To do this right-click in the Delay Measurements 
window, select Add. 

step iv. In the VehTravTmMeas column select the arrow. Select the Buzz Blvd EB 
and WB boxes. This will set the delay measurement to use the vehicle data 
from both Travel Time Measurement Zones. 

step v. Set Name to: Buzz Blvd EB and WB End-to-End.  
step vi. Next, we need to select delay performance metrics that should be collected.  

Click on the wrench icon  and select the following from the Delay 
Measurements Attributes: 
a. Stopped delay (average) → Current run x Current Interval x All Types 
b. Vehicle delay (average) → Current run x Current Interval x All Types 
c. Stops → Current run x Current Interval x All Types 
d. Vehicles → Current run x Current Interval x All Types 

There are numerous other metrics you could add. Feel free to explore the 
different metrics.   

step vii. Select OK. 

In the preceding steps the delay measurement zones, along with delay performance metrics 
to be collected, were set. If you run the model now you will see these attributes populate 
in the delay measurements window as the model is running. However, you will only see 
the data for the current interval, you will not see a record of the data for each interval. 
(Although, you could have, if you selected each interval individually from the attributes 
list.) As with the travel time data, for delay results aggregated over the intervals we will 
use a Results List.   

step i. Go to Evaluation → Configuration → Results Attributes. 
step ii. For Delays:  

a. Check the Collect data box 
b. Leave the From-time and To-time at 0 and 99999 
c. Set the Interval to 900.   

step iii. Go to Evaluation → Results Lists → Delay Results. 



step iv. Next, let’s select the delay attributes we would like to capture. Click on the 

wrench icon ( ) and select the following from the Delay Measurements 
Attributes: 

a. Delay measurement → Name 
b. Stopped delay (average) → All Types 
c. Stops → All Types 
d. Vehicle delay (average) → All Types 
e. Vehicles → All Types 

step v. Select OK. 

Save and run the model. In the delay results window you will see the selected performance 
metrics populate for each time interval, Figure 10. As with travel time, in the delays results 
window you can save the results by clicking on the disk icon ( ). If you select the disk 
icon with the red arrow ( ) the results file will be automatically saved at the end of each 
run. The file extension will be .att, with the term “Delay Results” in the file name.   

 
Figure 10: Sample from Delay Results list 

You may open the .att file in Excel (or any data analysis tool of your choice) for post-hoc 
analysis. As with the travel time data the file is semicolon delimited. Figure 11 shows a 
plot of the vehicle delay per interval for each delay measurement zone, generated using 
Excel.     



 
Figure 11: Sample vehicle delay per interval 

Next, as with travel time data, it may be desirable to output the individual vehicle delays 
over each delay measurement zone. However, we have already done this! The Direct 
Output file for the travel time raw data also contains the raw delay data. Open the travel 
time .rsr file to see the raw delay data. Only the individual delay measurement segments 
are included as the combined delay measurements consist of individual segments, thus 
would have the same raw data. Figure 12 shows the delay for vehicles end-to-end on Buzz 
Blvd (plotted using excel). In the figure the raw data was used to calculate the 15-minute 
averages as well, these are also plotted. Again, a comparison of the 15-minute averages 
calculated using the raw data and that from the Results List show the same aggregate values. 

 
Figure 12: Sample individual vehicle delay data 



You may notice when you explore the potential Results List Attributes for both travel time 
and delay that there are a number of attributes that are included in both lists. Once you have 
set up the delay and travel time measurements it is possible to include most of the 
performance metrics you are interested in within a single Results List. In addition, there is 
a tremendous wealth of potential performance metrics you may output, allowing for nearly 
endless analysis variations. Many of the outputs will prove useful in debugging the model 
or digging deeper to understand how the model is operating. It is highly encouraged to take 
some time and explore some of the many potential model result attributes.   

Volume and Speed – Data Collection Points.   
We will next explore two additional critical performance metrics, volume and speed. If 
desired, using the travel time data you may already calculate an average speed over the 
travel time measurement zones. Using Data Collection Points, we will measure speed and 
volume at a point. Data collection points are set up in a very similar manner to travel time 
measurements. First, we must place the desired Data Collection Points in the network. 
Data collection points are placed per lane. Next, we will define the Data Collection Point 
Measurements, i.e., utilizing single or groups of data collection points. Then we will set up 
the data collection interval and select the Results List desired Data Collection Point 
Attributes.  Finally, we will set up Direct Output of raw data.   

For our example network we will place data collect points at the arterial and freeway 
locations indicated in Figure 13. For demonstration purposes we will only add a few data 
collection points but you could add points at additional locations, as desired. We will place 
data collection points on Peach Freeway NB approximately 500’ south of the NB onramp 
gore; Buzz Blvd EB, approximately 250’ west of the freeway onramp; and on the Peach 
Freeway SB onramp and offramp, approximately half-way between the arterial intersection 
and freeway gore area. Data collection points are lane specific, thus you need to place a 
data collection point in each lane at each of these locations. 



 
Figure 13: Data Collection point locations 

To set up the Data Collection Points use the following steps: 

step i. Select Data Collection Points in the Network Objects. 
step ii. Right-click on the Buzz Blvd EB link at the desired location for the data 

collection point, Figure 13. Place a data collection point for each lane.   
step iii. In the Data Collection Points list fill in a Name for each point, i.e., Buzz 

Blvd EB, Upstream Onramp, Ln 1; and Buzz Blvd EB, Upstream Onramp, 
Ln 2. (Recall, lanes are numbered from the outside curb to the center of the 
roadway.) 

step iv. Repeat steps i, ii, and iii for the remaining data collection points identified 
in Figure 13. 

Next, we will set up the Data Collection Measurements. These will be the data collection 
point or points that will be used for grouping data. We will collect data at each individual 
data collection point, as well as for groups of data collection points, i.e., one group at the 
Buzz Blvd location and another group at the Peach Freeway NB location. This will allow 
for lane-by-lane analysis as well as directional analysis at each location.      

step i. Go to Evaluation → Measurement Definition → Data Collection 
Measurements. 

step ii. Right-click in the Data Collection Measurements window.  Select Generate 
all (1:1). 

Peach Freeway SB 
Offramp (1 ln) 

Peach Freeway SB 
Onramp (1 ln) 

Buzz Blvd EB (3 ln) 

Peach 
Freeway 
NB (3 ln) 



step iii. Right-click in the Data Collection Measurements window. Select Add. 
step iv. In the DataCollectionPoints column of the new row select the two Buzz 

Blvd Data Collection Points. Name the measure: Buzz Blvd EB, Upstream 
Onramp, All Ln. 

step v. Right-click in the Data Collection Measurements Window.  Select Add. 
step vi. In the DataCollectionPoints column select the three Peach Freeway Data 

Collection Points. Name the measure: Peach Freeway, Upstream Onramp, 
All Ln. 

The Data Collection Measurements list should look similar to Figure 14.   

 
Figure 14: Data Collection Measurements 

We could also add additional attributes to this table but instead we will go directly to setting 
up the Results List. 

step vii. Go to Evaluation → Configuration → Results Attributes. 
step viii. Click the Collect Data box for Data Collections; Set the Interval to 900. 
step ix. Go to Evaluation → Results List → Data Collection Results. 

 
By default, the Results List will include a number of attributes including: a 
count of vehicles crossing the data collection point - Vehs(All); as well 
arithmetic and harmonic average speeds, i.e., SpeedAvgArith(All) and 
SpeedAvgHarm(All). Also included is occupancy rate - OccupRate(All) - 
which is the percent-time-occupied, that is, the percentage of time a vehicle 
is physically activating the detector. Other attributes include: acceleration, 
distance, length, and queue delay. Definitions for each may be found in 
attributes list and in the Vissim manual. You may also use the wrench icon 
to add addition measurement attributes, as desired. You should take a 
moment and explore the available attributes.  

 



step x. Select the disk icon with the red arrow ( ), this will set the Results List to 
be saved to a file at the end of a run.     

step xi. Select the summation with circle icon ( ). At the end of the run Vissim 
will also include the aggregate statistics for the intervals, such as the min 
and max interval value, standard deviation across intervals (i.e., standard 
deviation of the 4, 15-minute interval values), etc.   

 
Save and run the model. As with the previous Results Lists an .att file is created. You can 
open this file in Excel (or other analysis software). Take a moment and review the file to 
see that the Data Collection data is now available in the file for further post-hoc analysis.   

Finally, we will generate the raw data collection point data. This will provide the individual 
vehicle data for each vehicle that crosses a data collection point. The raw data collected at 
each data collection point is: time a vehicle entered the data collection point, time a vehicle 
exits a data collection point, vehicle no., vehicle type, vehicle speed, acceleration, 
occupancy, persons in vehicle, time in queue, and vehicle length.   

step i. Go to Evaluation → Configuration → Direct Output. 
step ii. For Data Collection (raw data) select Write to file. 
step iii. Select OK. 

Save and run the file. The data collection points data will be saved in the same location as 
the .inpx file, as a .mer file. Open the file and confirm the data. For instance, Figure 15 is 
a plot of the speed data by entry time for the combined Buzz Blvd EB data collection points 
and Figure 16 is the speed data by entry time over the Peach Freeway data collection points. 
Interestingly, you will notice that some vehicles on the Freeway have speeds as high as 90 
mph. Is this reasonable? Go back to desired speed distribution you selected and check to 
see if speeds this high were allowed.   

 



 
Figure 15: Data Collection Point Speed from Buzz Blvd EB 

 

 
Figure 16: Data Collection Point Speed from Peach Freeway NB 

  

 

 

 

 



Graphical Display of Speed 
In addition to the results list and direct output it may also be helpful to review speeds 
graphically. To graphically display speed: 

step i. Select Links in Network Objects. 
step ii. Right-click on the left side of the Links menu. 
step iii. Left-click edit graphics parameters. 
step iv. Confirm Object visibility box is selected, Figure 17. 
step v. Left-Click Color Scheme Configuration, Figure 17. 
step vi. For Attribute select Speed (Current, Current, All).  
step vii. Select the color palette pull-down menu on the right-side of the Edit Color 

Scheme for Links Window and select speed, Figure 18. This will provide a 
default set of speed bounds and colors. You may adjust these as desired. 

step viii. Select OK. 
step ix. Return to the Links Edit Graphics Parameters List if it has closed.  
step x. Change the Drawing Mode to Use color Scheme. 

 
Figure 17: Network Object → Links → Edit Graphics Parameters menu 



 
Figure 18: Edit Color Scheme for Links 

step xi. Under the Evaluation Menu Select Configuration. 
step xii. Check Links in the Collect Data Column (if it is not already selected). 
step xiii. Select OK. 
step xiv. Select Links in Network Objects (if it is not already selected). 
step xv. Double right click on any link and open the Link dialogue window. 
step xvi. Select Others.  
step xvii. By default, Link evaluation should be checked. If it is not, check the box. 

Data will only be collected and visualized if this is checked.  If it was not 
you will likely need to check the other links in the network. (Clicking on 
each link to check if Link evaluation is active could be very tedious. To 
check this property for all links quickly show the link list, select attribute 
selection (i.e., click on the wrench icon), in the attribute pop-up window 
select Link evaluation active and use the green arrow to move it over to the 
displayed attributes.  The link list will now show this attribute for all links, 
allowing for a quick review.)  

step xviii. The link will be divided into segments for collecting, analyzing, and 
visualizing the data. The Segment Length box show the length of the 
segments.  For now, we will use the default, 32.8ft.     



Save and run the model. The link colors will now be updated based on the speed. This 
allows for a quick visual of the model performance. Figure 19 shows a screen capture 
during a model run.  

 
Figure 19: Example speeds within network.   

This can be a powerful means to quickly review a model and identify areas with low speeds, 
high speeds, etc. The colors will update every data collection interval as that is the attribute 
we selected. You could choose other speed metrics (total, min, max, etc.) or many other 
attributes (queues, volumes, etc.). In addition, under Edit Graphics Parameters you may 
also edit Link Bars, which will change the link thickness according to the performance 
metric value as well. 

Prior to proceeding to the next section, you may wish to go to Links → Edit Graphics 
Parameters → Drawing Mode. Return the drawing mode to use constant colors, otherwise 
in the subsequent runs you will continue to see the speed color scheme.    

 

Queue Data 
Next, we will review queue data. To obtain queue data we use Queue Counters in Network 
Objects. Queue counters are placed at the point you wish to start measuring the queue 
length. Generally, this will be at signal heads or conflict zones.  (In the next section we will 
see a way to automate the setting of queue counters using Nodes.) Queue length is measured 
in distance, not number of vehicles. 

Let’s set up Queue Counters for the intersection of Buzz Blvd and Burdell Dr. We will 
place a queue counter on each approach, at the signal heads, Figure 20.  

 



 
Figure 20: Queue Counter Locations for Buzz Blvd and Burdell Dr. 

Complete the following steps to set up the Queue Counters: 

step i. Select Queue Counters in Network Objects. 
step ii. Right-click on the Buzz Blvd EB Link and place a Queue Counter at the 

Signal Heads.  Be sure you are on the Buzz Blvd link and not the connector. 
You may find it easier to initially place the queue counter upstream of the 
signal heads and then drag it to the correct location.   

step iii. In the Queue Counter window fill in the Name, i.e., “Buzz and Burdell, 
EB”. 

step iv. Repeat steps ii and iii for the SB, WB, and NB approaches.   

The Queue Counters list should now be similar to Figure 21.    

 
Figure 21: Queue Counters List 

Queue Counter 
Locations 



As with the other metrics we could add additional attributes to this list but we will use the 
Results List for the queue data collection.   

step i. Go to Evaluation → Configuration → Results Attributes. 
step ii. Click on the Collect Data box in Queue Counters. 
step iii. Set the Interval to 300, that is, we will collect Queue Data in 5-minute 

intervals. 
step iv. Click on More…   You will see the Queue counters definition, Figure 22 

 
Figure 22: Queue Counters Definition 

These parameters define a queue. There are a number of finer points in 
queue measurements and the user is encouraged to review Queue Counters 
in the Vissim manual. However, briefly, for a queue to be initiated a vehicle 
must have a speed less than 3.1 mph, i.e., Begin speed < 3.1 mph. A vehicle 
is considered to no longer be in a queue when its speed exceeds 6.2 mph, 
i.e., End speed > 6.2 mph. Additionally, to be considered in a queue the 
headway between vehicles must be 65.6 ft or less, i.e., max. headway < 65.6.  
The max length sets the maximum queue length that will be reported.  
However, in the model the actual queue may be longer, this parameter 
allows for limiting the reported length, for instance, if as part of the analysis 
it is desired to consider an upstream section of the queue separately. 
Additionally, the queue length measured will also be limited by the presence 
of an upstream queue counter. Finally, if selected, Consider adjacent 
queues will include spillback into other lanes in the queue length. These 
parameters are all user adjustable. 
 

step v. Go to Evaluation → Results Lists → Queue Results. 
 

By default, the Queue Counter Result list includes Queue Length, Queue 
Length Maximum, and Queue Stops. There are a number of other attributes 
that you could include using the wrench icon. We will use the default 
parameters; however, take a moment and explore the other potential 
attributes.   
 



step vi. In the Queue Results window click the disk icon with the red arrow setting 
the results data to be automatically output to a file.   

Save and run the model. The Queue Results List should populate, similar to Figure 23.      

 
Figure 23: Sample Queue Results data 

As with the other Results Lists there is now an .att file for the queue results. Open that 
file in Excel (or other software) to confirm that the data has been recorded. Figure 24 
shows the average queue per 5-minute interval, plotted using Excel.    

 
Figure 24: Buzz Blvd and Burdell Drive Queue Lengths 

Unlike travel time, delay, and data collection results, queues do not have a Direct Output 
of raw data. This is because queuing data is not vehicle specific. If you need higher 
resolution data utilize shorter intervals in the Results List.    



Node and Link based Performance Measures 
An additional method to obtain performance metrics is to utilize the Nodes and Links 
model features.   

Links 
Performance metrics based on links are the rather straightforward. To collect Link based 
data, complete the following steps: 

step i. Go to Evaluation → Configurations → Results Attributes. 
step ii. Check the Collect data box for Links; Set the Interval to 900. 
step iii. Select More… for Links; Check the radio button per link segment. 
step iv. Go to Evaluation → Results Lists → Link Results. 

 
By default, the Results list will show a number of performance metrics for 
every link in the network, including density, relative delay, speed, volume, 
and a multitude of emissions metrics.  
 
Important note: Emissions data will only be available if you have purchased 
an external emissions API. We will not cover emissions in the modules; 
however, if you have the emissions API you can find additional information 
for its use in the Vissim manual.   
 

step v. Click the disk icon with a red arrow to output the Results List to a file. 

You can explore additional potential link attributes using the wrench icon. When you are 
done, save and run the model. Confirm the data is being captured. 

The use of Link based performance metrics is based on user preference. Some users prefer 
to construct the underlying network such that link based performance measures will 
quickly give the performance data needed without requiring the use of additional vehicle 
travel time measurements, data collection points, etc. I prefer to build the simplest 
underlying set of links and connectors possible, that capture the needed complexity, 
without worrying about the links being appropriate for data collection. Then I overlay the 
desired data collection measurements.  However, both approaches have their own benefits 
and challenges, and both may be acceptable if the developer is careful.     

Nodes 
Nodes provide a method to quickly collected data over a limited area of interest, such as an 
intersection or ramp junction. We will create a node for the intersection of Buzz Blvd and 
Ramblin St.   

To create a Node: 



step i. Select Nodes in the Network Objects. 
step ii. Draw a Node around the intersection. Right-click to start drawing the node, 

left-click to create a turning point in the node, double left-click at the last 
point and Vissim will then close the node. Your node should be similar to 
Figure 25. 
 

 
Figure 25: Buzz Blvd. and Ramblin St. Node 

 
step iii. The node pop-up window should be displayed. Fill in the Name as Buzz 

Blvd and Ramblin St., check the Use for evaluation box and the three 
Visualization boxes.   

step iv. Go to Lists → Network → Edges, the Edges list will show up under 
network editor. 

step v. The Edges list will be empty, right-click, select Create Evaluation Graph.  
This will create an entry for every path through each node (and connecting 
each node if more than one node is present). These are referred to as edges 
in VISSIM.  (Edges are essentially a simpler abstraction of the Vissim 
network).  Click on each row to highlight the edges. 

step vi. Go to Evaluations → Configuration → Results Attributes. 
step vii. Click the Collect data for Nodes; set the Interval to 60.  (Let’s collect some 

higher resolution data, i.e. one-minute intervals.) 
step viii. Select More…  

You will see the Nodes definition box. The queue definitions are the same 
as seen with the queue counters. The node will automatically set queue 
counters at all of the signal heads and the conflict markers. (We will 
demonstrate how to see queue counter locations below.) We will leave the 
default parameters. 



Nodes will also automatedly create travel time measurements for the 
calculation of delay, for each potential path through the node. The travel 
measurement will start upstream of the node entry point, a distance equal to 
the Start of delay segment, which in our case is 328 ft. (There are exceptions 
to this if you are using parking lots and dynamic assignment, please refer to 
the manual.) Where you have multiple nodes the travel time measurement 
starts immediately downstream of the closest node, as long as there are only 
four or fewer junctions between the nodes. The travel time measurement 
ends at the node exit boundary. Also, when defining multiple nodes be sure 
they do not overlap.   

(Caution: if you have vehicle queuing or other delay related to the node 
further upstream than the Start of delay segment value, that delay will NOT 
be accounted for in the delay measurement. The Start of delay value needs 
to be adjusted to capture the relevant delay; however, do not simply default 
to large values as you may then include delay that is unrelated to the node, 
i.e., the intersection of Buzz Blvd and Ramblin St. in this case. The modeler 
must be thoughtful in the setting of this value. Changing the Start of Delay 
under More… in either Results Attributes or Direct Output will change 
both.)   

step ix. Go to Evaluation → Results Lists → Node Results. 
step x. Select the disk icon with the red arrow. 
step xi. You should see a number of performance metrics already selected by 

default. You can see the additional potential attributes using the wrench 
icon. We will use the default attributes for now.   

 
In the Node Results list each edge is listed. You can determine the edge in 
a row by the Movement label. The Movement label will list as: Node Name 
- starting link @ position on starting link - ending link @ position on ending 
link. (If you want to confirm a position on a starting link use the ruler tool 
in the Network Editor.) A good naming scheme on your links makes reading 
this label much more straight forward! 

Save and run the model. The data should populate in the Results window. When the 
run is complete the .att file should be generated. Open the file to confirm the data is 
there. You can perform post analysis on this data. For instance, based on the output, is 
the intersection processing as many vehicles as you expected based on the vehicle input 
and routing decisions?  



You will notice that the Node Result List is reporting LOS (Level of Service). LOS is 
based on delay calculated as discussed previously. LOS levels are determined according 
to Figure 26.   

 
Figure 26: Level of Service Table:                                                                          

Source - PTV Vissim 11 User Manual, page 1082, accessed 4/15/21 

Where are the queue counters? When using the nodes, you might feel as if you are 
somewhat guessing the queue counters locations. Let’s set the node parameters so we 
can view the queues during the model run.   

step i. Right-click on Nodes in the Network Objects. 
step ii. Select Edit Graphics Parameters. 
step iii. In the pop-up make the follow edits, Figure 27, 

a. Select Object visibility. 
b. Select Label visibility. 
c. Select Show queue length. 
d. Set the Queue length attribute to QLEN(CURRENT,CURRENT). To 

do this click to the right of the row (three dots should show), expand 
Queue Length, select Current run x Current interval.   

e. Select a Queue Length Color (again, click to the right of the label). 
f. Select Show queue length label. 



step iv. Click outside the Edit Graphics window to close it.   
 
Save and run the model. You should see the queue lengths visually displayed on 
the model as well as the label for the length. Figure 28 show a screen shot part way 
through the run. You will notice that right turn queues are tracked at the merge 
point with the cross street, at the conflict marker. Also, the queue is an average of 
all lanes on a link. Thus, the left turn and through lanes report the same queue. If 
you wish to capture separate length for these movements you would need to use a 
separate link for the left turn bay, as discussed in Module 5.        

 
Figure 27: Nodes Edit Graphics window 



 
Figure 28: Sample queue length labels and graphics 

  

As with travel time and data collection points you may also write out the individual vehicle 
data from nodes to a file. Under Direct Output select Write to file and the From-time and 
To-time.  (While not discussed within these modules node data is one of the direct outputs 
that may also be written to a database file. For working with database files the user is 
referred to the Vissim manual.) 

 

  



Signal Controller Data 
Vissim has methods for writing signal control data to a file as well as several highly useful 
visualizations. 

For writing data to a file there is not a Results Attributes list.  There are however two direct 
outputs: Signal control detector data and Signal changes.  

Signal Controller Detector data 

This file contains data regarding numerous signal and detector parameters during runtime. 
To set Vissim to write out the Signal Controller Detector data: 

step i. Go to Evaluation → Configuration → Direct Output.  
step ii. Check the Write to file boxes for Signal control detector data. There are no 

intervals settings for this direct output as the given data will be collected as 
changes occur, for the entire simulation duration. The file will save to the 
same folder as the .inpx with the extension .ldp. 

step iii. Next we will set what data to include in the output file. Go to Signal Control 
→ Signal Controllers. 

step iv. The Signal Controllers / Signal Groups list should be open. Double-click 
on the Buzz Blvd and Burdell Dr. intersection. 

step v. The Signal Controller dialogue box should be open for this intersection. Go 
to the SC Detector Record Config tab. 

step vi. Within this tab select the signal parameters you would like to output. Select: 
a. Simul.Second, 
b. Cycle Second, 
c. Coordination Split – Ring 1, 
d. Coordination Split – Ring 2, 
e. Active Phase – Ring 1, 
f. Active Phase – Ring 2, 
g. Sig.Display SG – 111-2, 
h. Sig.Display SG – 111-4, 
i. Sig.Display SG – 111-6, and 
j. Sig.Display SG – 111-8. 

As you can see, there are a number of other parameters that could be 
selected.  For now we will use these.   

The SC Detector Record Config tab should look similar to Figure 29. 



 
Figure 29: Signal Controller, Buzz Blvd and Burdell Dr., SC Detector Record 

Config. 

step vii. Select OK. 
 

Before running the model let’s open the SC Detector Record window so we can also watch 
the data populate during runtime. Go to Evaluation → Window → SC Detector Record.  
Select the Buzz Blvd and Burdell Dr. intersection.   

Save and run the model. Pause the model at some point during the run. Within the SC 
Detector Record you can scroll through approximately the last 100 seconds of the model.  
You should see each of the parameters selected earlier.  (Note: For the Signal Display, the 
phase displays of Green, Yellow, and Red are indicated by “I”, “/”, and “.”, respectively) 

At the end of the run open the Buzz Blvd and Burdell Dr. .ldp file in Excel.  (I find this data 
is not split well by default in Excel. I use “Fixed Width” and then use the Data Preview to 
add a few additional columns as desired.)  A sample of the Excel output is seen in Figure 
30. (Aside, the .lpd files will be generated for the other signalized intersections. However, 
if you open them you will see the contain no data as we have not set their SC Detector 
Record Config.)   



 
Figure 30: Sample Excel Data. 

Signal Changes 
Signal Changes is a single file containing all signal indication changes for the network. To 
set Vissim to write out the Signal Changes data: 

step i. Go to Evaluation → Configuration → Direct Output.  
step ii. Check the Write to file boxes for Signal Changes. Again, there are no 

intervals settings for this direct output as the given data will be collected for 
the entire simulation duration. The file will save to the same folder as the 
.inpx as with the extension .lsa. 

Before running the model let’s open the Signal Changes window so we can also watch the 
data populate during runtime.  Go to Evaluation → Window → Signal Changes. The Signal 
changes window should now be open.  

Save and run the model. You should be able to see the Signal Changes window populate 
with the updated signal indications as the model progresses. The data should look similar 
to Figure 31. As with the SC Detector record you may pause the simulation and scroll 
through a limited amount of the data. The Signal Changes will be found in the .lsa file.   

 



 
Figure 31: Sample Signal Changes Window Output.   

Signal Times Table 
One last highly useful visualization for reviewing the signal control is the Signal Times 
Table. The Signal Times Table will visualize the Signal Group Status and Detector 
indications for each intersection. For example, Go to Evaluation → Window → Signal 
Times Table. In the pop-up window select the intersection of Buzz Blvd and Burdell Dr.  
Save and run the model. The Signal Times Table should populate for Buzz Blvd and 
Burdell Dr., showing the status of each SG and each detector, by cycle length, Figure 32.  

 
Figure 32: Sample Signal Times Table for Buzz Blvd and Burdell Dr. Intersection.   

There are a few handy features to the Signal Times Table. While the model is running 
select single step. Shift-left-click on the beginning of an event in the Signal Times table 
(say at the start of a detector actuation) and drag the mouse to the end of the event. In the 
lower left hand of the Signal Times table you will see the time between these two points. 
Also, you can slide the bar at the bottom of the window to see previous timings (up to a 
maximum of 5,000 secs.)  

For a given intersection you may further refine the contents of the Signal Times Table 
under Signal Control → Signal Controls → Signal Times Table Config. The current data 
being displayed is the default.  Deselect the Signal times table auto-configuration and 
make any desired changes.   



  

CONGRATULATIONS!!! 
 

You have completed      
Data and Performance 

Metrics!   
 

Way to go!!! 
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